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On some streaming web sites videos appear as a black box while SuperNova is running

When you attempt to view video content from some streaming web services (such as ctvnews.ca and tsn.ca), the area of the screen where the video is playing appears as a black, grey, or empty box.

Symptoms:


You may experience the following symptoms when trying to watch videos online:

  • When you attempt to view video content from a streaming service (such as ctvnews.ca and tsn.ca), the area of the screen where the video is playing appears as a black, grey, or empty box in the magnified view.
  • The rest of the webpage, including the video player controls, may magnify correctly, but the video content itself is not visible.
  • This issue can occur in all major web browsers, including Google Chrome, Microsoft Edge, and Mozilla Firefox.

Cause:


This issue is caused by Digital Rights Management (DRM) technology. Streaming services use DRM to protect their video content from being copied or recorded without authorisation.

This protection technology instructs the Windows operating system to block any software from capturing the video image. Because screen magnification works by capturing and enlarging a portion of the screen, SuperNova is blocked by this security measure.

This is an industry-wide security feature designed by content providers and affects all commercial screen magnification software using Microsoft's official Windows Graphics Capture API. It is not a bug in SuperNova.

Resolution:

To allow SuperNova to magnify DRM-protected video content, you can often resolve the issue by disabling the "Hardware Acceleration" setting within your web browser. This encourages the browser to play the video using a method that is compatible with commercial screen magnifiers that use Microsoft's official Windows Graphics Capture API.

Please Note: Disabling hardware acceleration may cause video playback to be less smooth and could increase your computer's CPU usage. Some streaming services may also limit video quality to Standard Definition (SD) when this setting is turned off.

To disable hardware acceleration, please follow the steps for your web browser in the table below. After changing the setting, you will need to restart your browser for the change to take effect.

Browser

Instructions to Disable Hardware Acceleration

Google Chrome

1. Open the Chrome menu (three vertical dots) and select Settings. 2. In the left-hand menu, select System. 3. Turn off the toggle for "Use graphics acceleration when available". 4. Select the Relaunch button that appears.

Microsoft Edge

1. Open the Edge menu (three horizontal dots) and select Settings. 2. In the left-hand menu, select System and performance. 3. Turn off the toggle for "Use graphics acceleration when available". 4. Select the Restart button that appears.

Mozilla Firefox

1. Open the Firefox menu (three horizontal lines) and select Settings. 2. In the General panel, scroll down to the Performance section. 3. Untick the box for "Use recommended performance settings". 4. A new option will appear. Untick the box for "Use hardware acceleration when available". 5. You will be prompted to restart Firefox for the changes to apply.